tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Looijmans, Mike" <mike.looijm...@oce.com>
Subject RE: about the version of HTTP protocol
Date Fri, 08 Jan 2010 08:36:58 GMT
>  I want to know does this Tomcat support HTTP/1.0 or HTTP/0.9 
> protocol.
> Pleas help me make sure of it.
>          I think the version of used HTTP protocol is 
> determined by browser, is it right? 

Tomcat still supports the older protocols. The browser determines the
version. Browsers have moved to 1.1 for decades, and were using
extensions to 1.0 that became standard in 1.1 for years before that. So
don't worry about the HTTP version.

The only case I know that may cause problems for 1.0 clients is when you
use virtual hosting. The "host" header is mandatory in 1.1, but was
optional in 1.0. Without the host header, the server must make a guess
as to what virtual host was intended, or you have to implement another
means of directing users to the correct application.

M.

>

This message and attachment(s) are intended solely for use by the addressee and may contain
information that is privileged, confidential or otherwise exempt from disclosure under applicable
law.

If you are not the intended recipient or agent thereof responsible for delivering this message
to the intended recipient, you are hereby notified that any dissemination, distribution or
copying of this communication is strictly prohibited.

If you have received this communication in error, please notify the sender immediately by
telephone and with a 'reply' message.

Thank you for your co-operation.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message