tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Okubo, Yasushi (TSD)" <Yasushi.Ok...@takedasd.com>
Subject RE: question for deploystartup forROOT.war on tomcat cluster
Date Mon, 25 Jan 2010 18:33:06 GMT
Thanks for your reply, but I do not see any errors and also cannot find
any configuration error.

 

-----Original Message-----
From: Konstantin Kolinko [mailto:knst.kolinko@gmail.com] 
Sent: Saturday, January 23, 2010 1:44 PM
To: Tomcat Users List
Subject: Re: question for deploystartup forROOT.war on tomcat cluster

 

2010/1/23 Okubo, Yasushi (TSD) <Yasushi.Okubo@takedasd.com>:

> 

>1. What attributes are set on the <Host> element of your server.xml

 

      <Host name="localhost"  appBase="webapps"

            unpackWARs="true" autoDeploy="true"

            xmlValidation="false" xmlNamespaceAware="false">

 

        <!-- SingleSignOn valve, share authentication between web
applications

             Documentation at: /docs/config/valve.html -->

 

        <Valve
className="org.apache.catalina.ha.authenticator.ClusterSingleSignOn" />

 

        <!-- Access log processes all example.

             Documentation at: /docs/config/valve.html -->

        <Valve className="org.apache.catalina.valves.AccessLogValve"
directory="logs"  

               prefix="webclust1_access_log." suffix=".log"
pattern="common" resolveHosts="false"/>

 

      </Host

 

 

http://tomcat.apache.org/tomcat-6.0-doc/config/host.html

 

>2. Are there any <Context> elements inside <Host> in your server.xml?

>Remove them, if there are any.

 

None.

 

>3. When ROOT fails to deploy at startup, does Tomcat Manager at that

>host shows any webapplication mapped to the same path? (E.g. present,

>but not started).

 

It is running by seeing from the manager, but it is not starting from
the log and by accessing from URL(hostname:port/).

 

 

OK - Listed applications for virtual host localhost
/manager:running:1:manager
/:running:0:/
/host-manager:running:0:host-manager

...

...

 


HTTP Status 404 - /

________________________________


type Status report

message /

description The requested resource (/) is not available.

 

 

>4. Any relevant messages in the log files?

 

No Error generated, but 

After Stop->Start or Reload from manager generates the following message

------------------------------------------------------------------------

Jan 25, 2010 10:18:43 AM org.apache.catalina.core.StandardContext start

INFO: Container
org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/] has
already been started

Jan 25, 2010 10:18:45 AM org.apache.catalina.core.StandardContext start

INFO: Container
org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/] has
already been started

Jan 25, 2010 10:26:25 AM org.apache.catalina.core.StandardContext reload

INFO: Reloading this Context has started

Jan 25, 2010 10:26:25 AM org.apache.catalina.ha.session.DeltaManager
stop

INFO: Manager [localhost#] expiring sessions upon shutdown

Jan 25, 2010 10:26:25 AM org.apache.catalina.ha.session.DeltaManager
start

INFO: Register manager localhost# to cluster element Engine with name
Catalina

Jan 25, 2010 10:26:25 AM org.apache.catalina.ha.session.DeltaManager
start

INFO: Starting clustering manager at localhost#

Jan 25, 2010 10:26:25 AM org.apache.catalina.ha.session.DeltaManager
getAllClusterSessions

WARNING: Manager [localhost#], requesting session state from
org.apache.catalina.tribes.membership.MemberImpl[tcp://{10, -6, -56,
33}:4000,{10, -6, -56, 33},4000, alive=436811673,id={-73 -106 -118 34 90
37 69 -120 -107 118 21 127 50 12 28 -85 }, payload={}, command={},
domain={}, ]. This operation will timeout if no session state has been
received within 60 seconds.

Jan 25, 2010 10:27:25 AM org.apache.catalina.ha.session.DeltaManager
waitForSendAllSessions

SEVERE: Manager [localhost#]: No session state send at 1/25/10 10:26 AM
received, timing out after 60,081 ms.

 

When I restart tomcat node [shutdown.sh/startup.sh], My ROOT.war needs
to read database and to initialize servlets as specified in its web.xml,
but it looks like it is not reading the data from database under cluster
setup like other applications do.

 

>Best regards,

>Konstantin Kolinko

 

---------------------------------------------------------------------

To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org

For additional commands, e-mail: users-help@tomcat.apache.org

 

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message