tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Okubo, Yasushi (TSD)" <Yasushi.Ok...@takedasd.com>
Subject form authentication error on tomcat cluster
Date Wed, 20 Jan 2010 18:47:58 GMT
Hi

 

I have configured tomcat cluster [v6.0.20] on linux box with
mod_proxy/mod_proxy_ajp [tomcat 6/Redhat 5/stickysession also turned on
for load balancer] on two different nodes. Each node is running one
tomcat instance.  I inserted cluster element under engine and turned on
jvmroute by setting up mod_proxy/mod_proxy_ajp. I also tested with
mod_jk, but both cases failed.

 

Anyway, when I turned on form authentication, it always generates the
error for the fist login attempt, but the second login attempt always
succeeds. 

I am getting:

HTTP Status 400 - Invalid direct reference to form login page

 

When I switched from form to basic authentication, the first login
attempt always succeeds. 

 

When I turned off mod_proxy/mod_proxy_ajp or mod_jk with very basic
simple cluster configuration also has this problem if I tried to use two
nodes [two physically different node by inserting cluster element under
engine element on server.xml].  If I moved cluster element to under host
element by setting up two tomcat instances on the same machine/node, the
first login attempts succeeds with form authentication. 

 

Is there any way to make form authentication work for the fist login
attempt with two different nodes?  

 

I am using clustersinglesignon. Even if I switch to singlesignon, the
result is consistent.

 

Any idea?

 

Thanks,

yasushi

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message