tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fatzopilot <fatzopi...@gmx.net>
Subject Re: Tomcat on Ubuntu 8.04 VPS and presumably multiple socket problems
Date Sat, 30 Jan 2010 16:41:44 GMT

Hi Chris,

Thank you for your response and time.
> Okay. Generally, it's considered polite to ask a single question in a
> single thread. Next time, just post them separately.
You are right and I would have done that but thought the issues might be
connected and caused by some low level system problem (firewall etc.) thence
I bundled them.
Luckily, meanwhile all issues are gone. Not sure what actually caused them
but I will post my assumptions.

> 1st issue: I cannot connect to a socket server embedded in a webapp and
> listening on port 10000 any more in all cases. If I do it from a mobile
> device, it works, if i do it from my laptop over a dsl connection (router
> in
> between), a channel is opened and instantly closed.
This seemed to be caused by connecting too fast to the socket server.
Lowering the sending frequency solved the issue.

> 2nd issue: mod_jk does not work. I think I replayed multiple instructions
> to
> set it up multiple times but in all cases it finally says "Could not find
> a
> worker for worker name=myWorker"

Solved by using the procedure described here (till item 11):
http://ubuntuforums.org/showthread.php?t=971517

I now use (for worker.properties):
workers.tomcat_home=/usr/share/tomcat5.5
workers.java_home=/usr/lib/jvm/java-1.5.0-sun
ps=/
worker.list=myWorker
worker.myWorker.port=8009
worker.myWorker.host=localhost
worker.myWorker.type=ajp13
worker.myWorker.lbfactor=1

which before was
workers.list=myWorker,ajp13
workers.myWorker.type=ajp13
workers.myWorker.host=localhost
workers.myWorker.port=8009

> 3rd issue: GWT-RPC calls do not get delivered any more to the browser on
> my
> laptop.
After having solved 1) I switched back to IPV6. Not sure if exactly this
caused the calls to work again but now they work :)

Cheers and sorry for bugging
fatzopilot


-- 
View this message in context: http://old.nabble.com/Tomcat-on-Ubuntu-8.04-VPS-and-presumably-multiple-socket-problems-tp27332135p27385269.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message