tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay McCoy <>
Subject Re: 404 for JSPs
Date Mon, 21 Dec 2009 05:12:26 GMT
Apparently Groovy 1.7 rc2 uses an outdated jsp api (2.0) and Tomcat 6 uses 2.1  This conflict
was causing me problems.  Of all the libraries, I was very surprised to see the conflict between
the latest Tomcat and Groovy.
Things still aren't right, but I don't know how to report what I am seeing yet.

On 12/20/09 10:24 PM, "Clay McCoy" <> wrote:

Thank you, this got me closer.  I have two questions:

1)  My current web.xml didn't configure the jsp servlet.  I haven't had do configure that
for a number of other containers.  I don't understand why I had to do this specifically for
Tomcat.  It also seems bizarre that the jsps worked without this jsp servlet in my standard
Tomcat deployment.  What should I have read to know about Tomcat needing a jsp servlet and
possibly other related gotchas?

2) I now get this error.  I'm guessing that this means that I need to do something to configure
my custom tags?

javax.servlet.ServletException: javax.servlet.jsp.tagext.TagAttributeInfo.<init>(Ljava/lang/String;ZLjava/lang/String;ZZLjava/lang/String;ZZLjava/lang/String;Ljava/lang/String;)V
    at org.apache.jasper.servlet.JspServlet.service(
    at javax.servlet.http.HttpServlet.service(
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(
    at org.apache.catalina.core.StandardWrapperValve.invoke(
    at org.apache.catalina.core.StandardContextValve.invoke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke(
    at org.apache.catalina.core.StandardEngineValve.invoke(
    at org.apache.catalina.connector.CoyoteAdapter.service(
    at org.apache.coyote.http11.Http11Processor.process(
    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(

On 12/20/09 8:56 PM, "Konstantin Kolinko" <> wrote:

2009/12/21 Clay McCoy <>:
> When I run embedded Tomcat my jsps 404, but my servlets work.

I guess that you do not have the Jsp servlet configured. See conf/web.xml.

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message