tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay McCoy <cmc...@acteksoft.com>
Subject Re: 404 for JSPs
Date Mon, 21 Dec 2009 04:24:22 GMT
Thank you, this got me closer.  I have two questions:

1)  My current web.xml didn't configure the jsp servlet.  I haven't had do configure that
for a number of other containers.  I don't understand why I had to do this specifically for
Tomcat.  It also seems bizarre that the jsps worked without this jsp servlet in my standard
Tomcat deployment.  What should I have read to know about Tomcat needing a jsp servlet and
possibly other related gotchas?

2) I now get this error.  I'm guessing that this means that I need to do something to configure
my custom tags?

javax.servlet.ServletException: javax.servlet.jsp.tagext.TagAttributeInfo.<init>(Ljava/lang/String;ZLjava/lang/String;ZZLjava/lang/String;ZZLjava/lang/String;Ljava/lang/String;)V
    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:275)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
    at java.lang.Thread.run(Thread.java:637)



On 12/20/09 8:56 PM, "Konstantin Kolinko" <knst.kolinko@gmail.com> wrote:

2009/12/21 Clay McCoy <cmccoy@acteksoft.com>:
> When I run embedded Tomcat my jsps 404, but my servlets work.

I guess that you do not have the Jsp servlet configured. See conf/web.xml.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message