tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dockery <dockeryjava...@yahoo.com>
Subject SSL only working on localhost
Date Wed, 02 Dec 2009 12:41:20 GMT




I have gotten ssl w/self-signed cert
  working on tomcat 6 a few times in the past.

I am trying it again on a different server

I am using port 443


when i attempt https://localhost
  via a browswer on the server itself
    the browser is properly presented with the cert warning (as i expected)

however, when i try to access https from another computer, 
 it just hangs... (and therefore NO cert warning)

i have wiresharked the server, and can see the inbound 443 connections,
 so the firewall does not seem to be the issue.
   (note: the other computers are on the same subnet/lan)

i have tried browsing to the servers ip, netbios name, fqdn/dns 
  with always the same result (below):
---    http is fine (the home page appears)
        ---    however httpS  does not do anything
                    (unless i browse from the server itself to itself)

further the logs do not show anything interesting
 and i have the log level set to debug.

ideas?



      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message