tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dockery <dockeryjava...@yahoo.com>
Subject Re: SSL only working on localhost
Date Thu, 03 Dec 2009 09:38:43 GMT
problem solved

the firewall exceptions were not config'ed correctly

it seems the 443 inbound packet was hitting the box
    but not hitting tomcat itself (due to fw dropping the packets)

i do however wonder for future ref,
 the best way to turn more logging-on for ssl

(even though in this case, logging would not have helped much
   ...except it would have been more obvious 
               that tomcat was NOT seeing the ssl attempts by the remote clients at all )

better logging ideas are welcomed.
  (as this might benefit others also)

I was hoping the global "debug" logging level 
 would have showm a bit more on the ssl connections, etc
  ...but i dont think it did that


fyi
Tomcat 6.0.13 
Java  1.6.017




________________________________
From: Guifre Bosch Fabregas <guifre.bosch@gmail.com>
To: Tomcat Users List <users@tomcat.apache.org>; pid@pidster.com
Sent: Wed, December 2, 2009 8:13:58 AM
Subject: Re: SSL only working on localhost

Can you see your page from another computer without SSL?
What's your OS?
Is it possible that "the problem" is the Firewall. Can you see the port 80
and 443 are open?




2009/12/2 Pid <pid@pidster.com>

> On 02/12/2009 12:41, Michael Dockery wrote:
>
>>
>>
>>
>>
>> I have gotten ssl w/self-signed cert
>>   working on tomcat 6 a few times in the past.
>>
>> I am trying it again on a different server
>>
>> I am using port 443
>>
>>
>> when i attempt https://localhost
>>   via a browswer on the server itself
>>     the browser is properly presented with the cert warning (as i
>> expected)
>>
>> however, when i try to access https from another computer,
>>  it just hangs... (and therefore NO cert warning)
>>
>> i have wiresharked the server, and can see the inbound 443 connections,
>>  so the firewall does not seem to be the issue.
>>    (note: the other computers are on the same subnet/lan)
>>
>> i have tried browsing to the servers ip, netbios name, fqdn/dns
>>   with always the same result (below):
>> ---    http is fine (the home page appears)
>>         ---    however httpS  does not do anything
>>                     (unless i browse from the server itself to itself)
>>
>> further the logs do not show anything interesting
>>  and i have the log level set to debug.
>>
>> ideas?
>>
>
> Idea: describe Tomcat, JVM, OS - precise versions please.
> Supply server.xml in use, comments removed.
>
>
> p
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>



      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message