tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <>
Subject Re: Debugging tomcat<->apache(mod_jk) bridge
Date Wed, 02 Dec 2009 16:33:53 GMT
Hash: SHA1


On 12/2/2009 11:06 AM, groupalias v wrote:
> In response to Chris' question -   I have only one tomcat instance
> running and it picks up the webapps in /srv/tomcat6/webapps/
> and the URL works fine.

- From what you posted earlier, you have a webapp in
/srv/tomcat6/webapps/A, which should be accessed via a URL such as:

If you have a webapp deployed into /srv/tomcat6/webapps/test, you didn't
mention it (and it's important information). If you have no webapp
deployed into /srv/tomcat6/webapps/test, then it will use the default
webapp which will be in /srv/tomcat6/webapps/ROOT unless otherwise
configured. If you have neither of these, I would fully expect to get a
400 error because does not map to any
configured webapp.

> I tried with the mod_jk.c and jk_module with the same result.

I don't think mod_jk is the problem, here.

Tomcat does not produce a log message when a webapp cannot be found, and
you can see mod_jk returning a 400 from Tomcat. I believe this is a
webapp deployment problem.

> What is the workers.tomcat_home directive in used for?

Nothing. It is an old configuration option that is no longer used.

> If the communication is over the 8009 port why does apache care about
> one of tomcat's directories?

It doesn't.

- -chris
Version: GnuPG v1.4.10 (MingW32)
Comment: Using GnuPG with Mozilla -


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message