tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DOrlov <dor...@redaril.com>
Subject TomCat 6 performance issues
Date Tue, 22 Dec 2009 05:36:07 GMT

Hello.
I have TomCat server on production and have from 80 up to 400 requests per
second.

In server.xml I have next connector description:

 <Connector port="80"
               maxThreads="200"
               acceptCount="100"
               minSpareThreads="5"
               maxSpareThreads="75"
               enableLookups="false"
               disableUploadTimeout="true"
               connectionTimeout="1500"
               keepAliveTimeout="0"
               maxKeepAliveRequests="1"
               />

For application spesific we don't need to support keep alive and don't need
to wait for huge requests.
Main task is to serve responses as fast as we can.

~Time for request processing on server (I use tomcat log figures and own
time counters for checking) is 1 ms.

PROBLEM now:
Most part of time server works fine and ~ time for request/response 300 ms
(for external users via browser)

BUT time to time request/response time is upto 5 seconds for the same users.
How I could figure out a problem? How could I check if it is Tomcat server
problem or not?

You are very welcome with comments.

Thanks,
Denis.



-- 
View this message in context: http://old.nabble.com/TomCat-6-performance-issues-tp26884227p26884227.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message