tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Hiller <d...@alvazan.com>
Subject starting tomcat from ant not working
Date Mon, 02 Nov 2009 05:16:51 GMT
I have tried from ant and programmed up a main class to start tomcat via
"catalina.bat start" and tried "catalina.bat start" from ant as well.
Lastly, I finally tried directly running the exact command that catalina.bat
start tries to run and then ended up with classnotfound which makes no sense
since I thought the bootstrap class is supposed to put that
together.....(any ideas?)

     [echo] os=Windows Vista
     [java] Executing 'C:\AAROOT\Java\jdk1.6.0_16\jre\bin\java.exe' with
arguments:
     [java] '-classpath'
     [java] 'D:\workarea\tomcat\bin\bootstrap.jar;D:\workarea\tomcat\bin'
     [java] 'org.apache.catalina.startup.Bootstrap'
     [java]
'-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager'
     [java]
'-Djava.util.logging.config.file=d:\workarea\tomcat/conf/logging.properties'
     [java] '-Djava.endorsed.dirs=d:\workarea\tomcat/endorsed'
     [java] '-Dcatalina.base=d:\workarea\tomcat'
     [java] '-Dcatalina.home=d:\workarea\tomcat'
     [java] '-Djava.io.tmpdir=d:\workarea\tomcat/temp'
     [java] 'start'
     [java]
     [java] The ' characters around the executable and arguments are
     [java] not part of the command.
     [java] java.lang.ClassNotFoundException:
org.apache.catalina.startup.Catalina
     [java]     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
     [java]     at java.security.AccessController.doPrivileged(Native
Method)
     [java]     at
java.net.URLClassLoader.findClass(URLClassLoader.java:188)
     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
     [java]     at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
     [java]     at
org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:215)
     [java]     at
org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:390)
    [sleep] sleeping for 60000 milliseconds

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message