tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid <...@pidster.com>
Subject Re: Tomcat Native with Apr not initializing on 8443 with SSL
Date Fri, 27 Nov 2009 12:20:31 GMT
On 27/11/2009 11:15, occup_hazard wrote:
>
> Nov 27 02:28:19 emr jsvc.exec[14439]: Nov 27, 2009 2:28:19 AM
> org.apache.coyote.http11.Http11AprProtocol init INFO: Initializing Coyote
> HTTP/1.1 on http-8080
> Nov 27 03:27:07 emr jsvc.exec[14439]: Nov 27, 2009 3:27:07 AM
> org.apache.coyote.http11.Http11AprProtocol init INFO: Initializing Coyote
> HTTP/1.1 on http-8443
> Nov 27 03:27:07 emr jsvc.exec[14439]: Nov 27, 2009 3:27:07 AM
> org.apache.coyote.ajp.AjpAprProtocol init INFO: Initializing Coyote AJP/1.3
> on ajp-8009
> Nov 27 03:27:07 emr jsvc.exec[14439]: Nov 27, 2009 3:27:07 AM
> org.apache.catalina.startup.Catalina load INFO: Initialization processed in
> 3529869 ms
> Nov 27 03:27:08 emr jsvc.exec[14439]: Nov 27, 2009 3:27:08 AM
> org.apache.catalina.core.StandardService start INFO: Starting service
> Catalina
> Nov 27 03:27:08 emr jsvc.exec[14439]: Nov 27, 2009 3:27:08 AM
> org.apache.catalina.core.StandardEngine start INFO: Starting Servlet Engine:
> Apache Tomcat/5.5.27
> Nov 27 03:27:08 emr jsvc.exec[14439]: Nov 27, 2009 3:27:08 AM
> org.apache.catalina.core.StandardHost start INFO: XML validation disabled
> Nov 27 03:27:12 emr jsvc.exec[14439]: Nov 27, 2009 3:27:12 AM
> org.apache.coyote.http11.Http11AprProtocol start INFO: Starting Coyote
> HTTP/1.1 on http-8080
> Nov 27 03:27:13 emr jsvc.exec[14439]: Nov 27, 2009 3:27:13 AM
> org.apache.coyote.http11.Http11AprProtocol start INFO: Starting Coyote
> HTTP/1.1 on http-8443
> Nov 27 03:27:13 emr jsvc.exec[14439]: Nov 27, 2009 3:27:13 AM
> org.apache.coyote.ajp.AjpAprProtocol start INFO: Starting Coyote AJP/1.3 on
> ajp-8009
> Nov 27 03:27:13 emr jsvc.exec[14439]: Nov 27, 2009 3:27:13 AM
> org.apache.catalina.storeconfig.StoreLoader load INFO: Find registry
> server-registry.xml at classpath resource
> Nov 27 03:27:14 emr jsvc.exec[14439]: Nov 27, 2009 3:27:14 AM
> org.apache.catalina.startup.Catalina start INFO: Server startup in 6468 ms
>
>
> Ok so it started up after a Hour..........What could be the reason, is there
> some kinda tuning required...?
>
> Please advice..

You've got an AJP connector there, do you need that?
If not, comment it out.

I've experienced an HTTPD taking a long time to start up because the 
random source initialisation was slow.  APR is probably using the same 
code libs.  Try commenting out

<Listener className="org.apache.catalina.core.AprLifecycleListener" 
SSLEngine="on" />

at the beginning of server.xml.

Then see if the startup is quicker.


p



> occup_hazard wrote:
>>
>> Hi all,
>>
>> I am running Ubuntu (Hardy), have tomcat5.5 installed for hardy repo, Apr
>> 1.2.11 ( libapr1-dev), OpenSSL 0.9.8g (libssl-dev), tcnative 1.1.13, jsvc
>> 1.0.2, openjdk-6-jdk and openjdk-6-jre.
>>
>> Now without SSL set ( not listening on 8443) in server.xml, the tomcat
>> server starts up fine.
>>
>> With SSL
>>
>> Nov 27 00:52:01 emr jsvc.exec[13418]: Nov 27, 2009 12:52:01 AM
>> org.apache.coyote.http11.Http11AprProtocol init INFO: Initializing Coyote
>> HTTP/1.1 on http-8080
>>
>> It just waits there forever no  error messages either, I need to have SSL
>> implemented in tcnative, any ideas...
>>
>>
>>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message