tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Tomcat 6.0.20 on 64bit Window2003 - 64bit Service CAN'T start
Date Mon, 02 Nov 2009 22:38:21 GMT
Tiffany.Dinh@inovis.com wrote:
> I installed Tomcat 6.0.20 on 64bit Window2003. I installed 64 bit tomcat service (64
bit tomcat6.exe and 64bit tomcat6w.exe).

  I set variable name of JRE_HOME to the path of my 64bit JRE 6.0.

Where did you set that variable ?

When running Tomcat as a service under Windows, using the tomcat6.exe 
wrapper, the environment parameters, path to JVM etc.. have to be set 
using the tomcat6w.exe program.  This is a GUI (graphical) program, 
which you start on the console just by double-clicking on it.

A bit of explanation, which is available somewhere else in the docs but 
I don't remember where :
Tomcat is a Java program.
It is run by a JVM.
The JVM is thus the real program which runs under Windows.
But the JVM, by itself, does not react very well like a Windows Service 
is expected to.
So someone invented a "wrapper program", which gets installed and acts 
as the Windows Service; and this program runs the JVM.
That wrapper program is tomcat6.exe.
This wrapper program looks for some of its parameters, in the Windows 
Registry.
The tomcat6w.exe program is a GUI programs that helps setting these 
Registry parameters in the right place.

So start tomcat6w.exe, and navigate through the tabs, to see where it 
thinks it should find the JVM.  Your problem is probably there.




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message