tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ndunn1979 <ndunn...@earthlink.net>
Subject Apache Tomcat Connector (AJP13) is corrupting html content
Date Thu, 12 Nov 2009 15:07:13 GMT

I am experiencing an odd issue using AJP13 to connect Apache up to Tomcat.
I've gotten it all setup and working for small pages, but I have a use case
where Tomcat serves a very large page >300KB. In this particular case, the
page does not load completely. Sections of the html are duplicated, and some
sections are omitted. I've searched all the logs I can think of (Apache's
mod_jk and error.log, and Tomcat's stdout, stderr, and the catalina log
file). I've cranked up the mod_jk log to level 3 and I can see the html
content coming through in chunks, but the chunks are not synched up
correctly. I tried increasing the max packet size to 65536 (both in
workers.properties and in the server.xml), but I didn't really expect that
to work since it would still require the data to be chunked up.

I'm using Apache 2.2 with Tomcat 5.5 on a Windows XP box. Firewall is
disabled at the moment to rule that out. I've found posts describing issues
with very large POST data and issues related to SSL, but nothing similar to
what I'm experiencing. It's very possible I didn't configure something
correctly, but it is mostly working and I used sample versions of
workers.properties and JkMount directives. I've read through the Tomcat
Connector documentation but there are no settings that appear relevant.

I'm stumped...Hopefully someone can help.

Here is a snippet of the mod_jk log file.

[Thu Nov 12 08:24:04.640 2009] [2104:2368] [debug] jk_ajp_common.c (1259):
03e0    3E 0A 0A 3C 74 72 20 63 6C 61 73 73 3D 22 61 6C  - >..<tr.class="al
[Thu Nov 12 08:24:04.640 2009] [2104:2368] [debug] jk_ajp_common.c (1259):
03f0    74 65 72 6E 61 74 65 52 6F 77 22 3E 0A 3C 74 64  - ternateRow">.<td
[Thu Nov 12 08:24:04.640 2009] [2104:2368] [debug] mod_jk.c (506): written
8184 out of 8184
[Thu Nov 12 08:24:04.656 2009] [2104:2368] [debug] jk_ajp_common.c (1259):
received from ajp13 pos=0 len=2 max=65536
[Thu Nov 12 08:24:04.656 2009] [2104:2368] [debug] jk_ajp_common.c (1259):
0000    05 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00  - ................
[Thu Nov 12 08:24:04.656 2009] [2104:2368] [debug] jk_ajp_common.c (1846):
AJP13 protocol: Reuse is OK
[Thu Nov 12 08:24:04.656 2009] [2104:2368] [debug] jk_ajp_common.c (743):
(ajp13) resetting endpoint with sd = 1480 
[Thu Nov 12 08:24:04.656 2009] [2104:2368] [debug] jk_ajp_common.c (2905):
recycling connection pool slot=0 for worker ajp13
[Thu Nov 12 08:24:04.656 2009] [2104:2368] [debug] mod_jk.c (2599): Service
finished with status=200 for worker=ajp13

-- 
View this message in context: http://old.nabble.com/Apache-Tomcat-Connector-%28AJP13%29-is-corrupting-html-content-tp26320290p26320290.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message