tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From thomas2004 <thomas200...@yahoo.de>
Subject A question about mod_jk 1.2.28 configuration
Date Mon, 09 Nov 2009 10:27:03 GMT

I newly installed the mod_jk 1.2.28 and since then got problem (see below).

**********************
We have a web application deployed on Jboss (RH Linux OS). The access to the
web application is via a Apache Httpd Web Server. One of the function of
this web application is one can online generate PDF-reports. This report
could by quite big (30 MB). After the report is generated (this will take
about 20 to 40 min.) it will show up on the browser.

Formerly we have mod_jk 1.2.26 and everything is ok. Since a week we update
the mod_jk to 1.2.28 and got problem. Exactly to say, the PDF-report can not
be shown up on browser. One can find some error messages in mod_jk.log as
follow:

Code:

[Tue Nov 03 11:03:07 2009] [12138:2537062720] [info]
ajp_connection_tcp_get_message::jk_ajp_common.c (1150):
(worker_portfolio_son1) can't receive the response header message from
tomcat, network problems or tomcat (172.23.17.37:8009) is down (errno=11)
[Tue Nov 03 11:03:07 2009] [12138:2537062720] [error]
ajp_get_reply::jk_ajp_common.c (1962): (worker_portfolio_son1) Tomcat is
down or refused connection. No response has been sent to the client (yet)
[Tue Nov 03 11:03:07 2009] [12138:2537062720] [info]
ajp_service::jk_ajp_common.c (2447): (worker_portfolio_son1) sending request
to tomcat failed (recoverable), (attempt=2) [Tue Nov 03 11:03:07 2009]
[12138:2537062720] [error] ajp_service::jk_ajp_common.c (2466):
(worker_portfolio_son1) connecting to tomcat failed. [Tue Nov 03 11:03:07
2009] worker_portfolio_son1 citibank-extranet-ru-test.civ-versicherung.de
244.108419 [Tue Nov 03 11:03:07 2009] [12138:2537062720] [info]
jk_handler::mod_jk.c (2615): Service error=0 for
worker=worker_portfolio_son1

>From google I know this could be a problem of reply_timeout. I set the
reply_timeout in workers.properties but it doesn't help. Here is my
"workers.properties".

Code:

worker.list=jkstatus, worker_portfolio_son1
worker.worker_portfolio_son1.connection_pool_timeout=600
worker.worker_portfolio_son1.socket_timeout=120
worker.worker_portfolio_son1.socket_keepalive=True
worker.worker_portfolio_son1.lbfactor=1
worker.worker_portfolio_son1.type=ajp13
worker.worker_portfolio_son1.port=8009
worker.worker_portfolio_son1.host=appl-portfolio-test.proactiv.de
worker.worker_portfolio_son1.sticky_session=True
worker.worker_portfolio_son1.reply_timeout=3600000


-- 
View this message in context: http://old.nabble.com/A-question-about-mod_jk-1.2.28-configuration-tp26264069p26264069.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message