tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Brittain <jason.britt...@gmail.com>
Subject Re: Multiple instances using catalina.base
Date Thu, 01 Oct 2009 20:57:06 GMT
Does your CATALINA_BASE's catalina.properties file have completely stock
settings?  What is "common.loader" set to in there?  It appears that you
have it set up right, and your startup output shows good environment
variable and Java values.  You should not need to copy the CATALINA_HOME/lib
dir into your CATALINA_BASE.

--
Jason Brittain


On Thu, Oct 1, 2009 at 11:57 AM, Vinicius Carvalho
<java.vinicius@gmail.com>wrote:

> Hello there! I've followed the instructions on RUNNING.TXT and a great
> presentation by Mark Thomas and Filip Hanik I've found on the net. But
> after creating a directory structure:
>
> /tomcat-6.0.20 {catalina_home}
>  - bin
>  - conf
>  - webapps
>  -work
>  - temp
>  - lib
>  - logs
>  - instance-01 {catalina_base}
>  -bin
>  -logs
>  -conf
>  -webapps
>  -temp
>  -work
>
> I've just added server.xml and catalina.properties to conf, and
> setenv.sh to bin of my catalina_base instance.
>
> But after exporting the CATALINA_BASE and running startup.sh:
>
>
> Using CATALINA_BASE:   /home/vinicius/java/apache-tomcat-6.0.20/instance-01
> Using CATALINA_HOME:   /home/vinicius/java/apache-tomcat-6.0.20
> Using CATALINA_TMPDIR:
> /home/vinicius/java/apache-tomcat-6.0.20/instance-01/temp
> Using JRE_HOME:       /usr/lib/jvm/java-6-sun
>
> I get this at my catalina.out
>
> java.lang.ClassNotFoundException: org.apache.catalina.startup.Catalina
>        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
>        at java.security.AccessController.doPrivileged(Native Method)
>        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
>        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
>        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
>        at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:215)
>        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:390)
>
>
> Can't figure out what am I doing wrong. I don't think I need to copy lib
> folder.
>
> Any ideas?
>
> Regards
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message