tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: VirtualHost configuration working in Tomcat 5.5 does not workin Tomcat 6.0.20
Date Sun, 11 Oct 2009 14:33:37 GMT
> From: Pid [mailto:pid@pidster.com]
> Subject: Re: VirtualHost configuration working in Tomcat 5.5 does not
> workin Tomcat 6.0.20
> 
> <Host name="mydomain.net" appBase="/path/to/website/appBase"
>         unpackWARs="true" autoDeploy="true"
>         xmlValidation="false" xmlNamespaceAware="false">
>        </Host>
> 
> <Host name="mydomain.net" appBase="/path/to/redirect/appBase"
>         unpackWARs="true" autoDeploy="true"
>         xmlValidation="false" xmlNamespaceAware="false">
>        </Host>
> 
> You don't need the Context definition if that is all you had configured
> on it.

Actually, if that's all there is for the virtual hosting, the OP doesn't need it at all. 
Simply remove the second <Host> (the one not pointed to by the <Engine> defaultHost
attribute); all requests will end up at the same place anyway.

In general, it's a bad idea to just copy configuration elements from one level of Tomcat to
another.  Better to understand what they do in the older version, read the doc for the new
one, and generate the necessary config as appropriate.  Some subtleties can easily catch you
out otherwise.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message