tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Getting an error with the Tomcat Manager on version 6.0.14.
Date Wed, 07 Oct 2009 17:44:48 GMT
> From: Razvan Poenaru [mailto:Razvan.Poenaru@mdacorporation.com]
> Subject: Getting an error with the Tomcat Manager on version 6.0.14.
> 
> I am getting the following error when trying to access the Tomcat
> Manager on Tomcat 6.0.14:

Access it how?

> root cause
> java.lang.SecurityException: Servlet of class
> org.apache.catalina.manager.HTMLManagerServlet is privileged and cannot
> be loaded by this web application

Looks like you may have lost the privileged="true" attribute in the manager's <Context>
element.  Look in [appBase]/manager/META-INF/context.xml and see what it says.  Also check
if there's a conf/Catalina/[host]/manager.xml that might be overriding the one packaged with
the webapp.

Any reason you can't move up to a newer version?

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.

Mime
View raw message