tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Connection between ListenerStart and clustering
Date Wed, 28 Oct 2009 17:57:38 GMT
Thanks for letting us know!

On 28.10.2009 16:23, Bocalinda wrote:
> Hi again Rainer,
> 
> It seems some of our software updates must have solved the issue, as it's
> been working perfectly now for several weeks.
> I think we may conclude that it didn't had to do with the the clustering
> implementation.
> I feel sorry that you put time into patching the issue. In case the problem
> ever comes up again, the first thing I'll do is test the patch you've sent.
> 
> Thanks a lot.
> 
> 2009/10/14 Bocalinda <bocalinda@gmail.com>
> 
>> Hi Rainer,
>>
>> I'm sorry for the long delay in getting back to you.
>> I got sidetracked by another issue and wasn't able to look into this
>> earlier.
>>
>> However, the bad news is that the administrators didn't allow me to apply
>> the patch as it is a production server.
>> I can apply it to pre-production, but the error isn't reproducable there...
>>
>> 2nd however; It's been 12 days since we've seen the listenerStart error due
>> to the classDefNotFound (in production).
>> I need to check with the developers whether they accidentily made any
>> changes that might have solved this problem.
>> It might as well be that we have been lucky and that the error starts
>> appearing again tomorrow.
>>
>> I will try to reproduce the problem in another server, in order to try out
>> the patch you supplied.
>>
>> Thanks again.
>>
>>
>> 2009/10/3 Bocalinda <bocalinda@gmail.com>
>>
>>> Wow, that's what is called a quick turn around! :)
>>>
>>> Thanks. I'll try as soon as possible and let you know.
>>>
>>> 2009/10/3 Rainer Jung <rainer.jung@kippdata.de>
>>>
>>> On 03.10.2009 18:11, Bocalinda wrote:
>>>>> Hi Rainer.
>>>>>
>>>>> <wild guess>
>>>>>> I remember problems with clustering which were of the following kind:
>>>>>> session replication data was received on a node although the context
>>>>>> wasn't yet fully initialized.
>>>>>>
>>>>>> Maybe we run into classloader troubles in that case?
>>>>>>
>>>>>> This could only happen if another node in the cluster is running
all
>>>> the
>>>>>> time between stop and restart of the node, which logs the exception.
>>>>>>
>>>>>> This could certainly be the case as I have 4 nodos in cluster. I
>>>>> stop/restart one by one, in order to ensure the availability of the
>>>> webapp.
>>>>>
>>>>>
>>>>>> How easy can your reproduce the problem? In case I provide a patch,
>>>>>> could you test, whether the problem goes away?
>>>>>> </wild guess>
>>>>>>
>>>>>>
>>>>> Taking into account that this is a production server, it won't be easy
>>>> to
>>>>> play with it, but I can propose to take 2 nodes out of the cluster to
>>>> do
>>>>> testing with.
>>>>
>>>> You can find a patched catalina-ha.jar and in case you are interested
>>>> also the respective source code file at
>>>>
>>>>
>>>> http://people.apache.org/~rjung/patches/tc6-cluster-context-startup-order.zip<http://people.apache.org/%7Erjung/patches/tc6-cluster-context-startup-order.zip>
>>>>
>>>> I did a one to one port from TC 5.5 to TC 6.0. So please test carefully
>>>> and let us know the results, so we can include the patch into the
>>>> standard code in case it proves it helps.
>>>>
>>>> Regards,
>>>>
>>>> Rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message