tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: resource not available : Apache Tomcat/6.0.20 with java jdk1.6.0_16 on linux 2.6.30.1
Date Mon, 05 Oct 2009 11:04:32 GMT
Peter Crowther wrote:
...

> and Tomcat in general.  Symlinks in webapps will not work by default -
> look up "allowLinking" to allow them, and be Very Careful if you do as
> I seem to recall that undeploying a webapp with a symlink in it can
> delete all the files in the area that you've linked to.
> 
As things happen, I just spent 2 hours this morning wondering why an old 
webapp that worked fine under Tomcat 4.1, didn't work anymore when moved 
to Tomcat 5.5.  Until I saw your message above, and added a context.xml 
in the webapp with allowLinking=true.
It seems that the old Tomcat 4.1 had such a <Context> element in 
server.xml, which disappeared in the move to 5.5.

(catalina_base)/webapps/myapp/META-INF/context.xml :
<Context allowLinking="true" />

did it.

Thanks.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message