tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ramkmpaa2 <mpofficew...@gmail.com>
Subject Unable to get the free endpoint for worker AG2 from 10 slots in IIS7 with JBOSS430
Date Tue, 20 Oct 2009 10:57:24 GMT

Hi all I have configured the JBOSS 430 with IIS7 for a single node as per the
guide available in the location
http://www.scribd.com/doc/20684887/IIS7-with-JBOSS-430.

I have used isapi_redirect1.2.28.dll in IIS configuration.

After sometime accessing the application, I can see the following in the
Isapi log file.. Can some one help me out on this?

uriworkermap.properties
/awebapp=loadbalancerAG
/awebapp/=loadbalancerAG
/awebapp/*=loadbalancerAG

Workers.properties:
# Define list of workers that will be used
# for mapping requests
# Note worker list does not include the nodes
worker.list=loadbalancerAG,status
# Define Node2
# modify the host as your host IP or DNS name.
worker.AG2.port=8009
worker.AG2.host=rentsrv15s2.agi.com
worker.AG2.type=ajp13
worker.AG2.lbfactor=1
worker.AG2.connection_pool_size=10
# Load-balancing worker
worker.loadbalancerAG.type=lb
worker.loadbalancerAG.balance_workers=AG2
worker.loadbalancerAG.sticky_session=1
# Status worker for managing load balancer
worker.status.type=status


Error in isapi_redirect.log file:
[Tue Oct 20 03:13:02.908 2009] [3420:4024] [info] jk_ajp_common.c (1496):
(AG2) all endpoints are disconnected, detected by connect check (3), cping
(0), send (0)
[Tue Oct 20 03:13:25.846 2009] [3420:4024] [info] jk_ajp_common.c (1496):
(AG2) all endpoints are disconnected, detected by connect check (1), cping
(0), send (0)
[Tue Oct 20 03:14:40.238 2009] [3420:3976] [info] jk_ajp_common.c (1496):
(AG2) all endpoints are disconnected, detected by connect check (1), cping
(0), send (0)
[Tue Oct 20 03:15:02.988 2009] [3420:988] [info] jk_ajp_common.c (1496):
(AG2) all endpoints are disconnected, detected by connect check (1), cping
(0), send (0)
[Tue Oct 20 03:17:42.131 2009] [3420:3976] [info] jk_ajp_common.c (1496):
(AG2) all endpoints are disconnected, detected by connect check (5), cping
(0), send (0)
[Tue Oct 20 03:18:25.522 2009] [3420:988] [warn] jk_ajp_common.c (3001):
Unable to get the free endpoint for worker AG2 from 10 slots
[Tue Oct 20 03:18:25.522 2009] [3420:988] [info] jk_lb_worker.c (1185):
could not get free endpoint for worker AG2 (0 retries)

Thanks
Ram
-- 
View this message in context: http://www.nabble.com/Unable-to-get-the-free-endpoint-for-worker-AG2-from-10-slots-in-IIS7-with-JBOSS430-tp25973154p25973154.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message