tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kreshna Aryaguna Nurzaman <kreshna_icehe...@yahoo.com>
Subject Re: Installing Tomcat: how much do versions matter?
Date Sat, 03 Oct 2009 05:24:38 GMT

Thanks, Chris! It's a really helpful reply :-)

The good news is that the latest version of ArcIMS support both Apache 2.2
and 2.0 branch. Guess I better use the latest.

-Kresh


Christopher Schultz-2 wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Kresh,
> 
> On 10/2/2009 10:49 AM, Kreshna Aryaguna Nurzaman wrote:
>> Tomcat-wise, will there be any problems to accept slight differences in
>> version? For example, is it okay if I use Apache 2.2.4 with Tomcat
>> 6.0.20?
>> And how about Tomcat connector? For example, is it possible to use Apache
>> 2.0.63 while using mod_jk2-2.0.43.dll connector?
> 
> Generally speaking, minor versions within the same branch (like 6.0.13
> versus 6.0.18 versus 6.0.20) should be compatible. Always be sure to
> read the change log and/or release notes for the intervening versions
> between the "approved" version and the one you intend to use to see if
> any possible breaking-changes have been made. Usually, anything that
> might break something has a configuration parameter that will set it
> back to the old behavior.
> 
> I would take whatever version is recommended by the software vendor and
> then move up to the latest point-release for that version. So, if Apache
> httpd 2.2.4 is approved for your software, I would go ahead and use
> 2.2.13 (the latest in the 2.2 branch) or if 2.0.50 is approved, then go
> ahead and use 2.0.63 (the latest in the 2.0 branch). The same can be
> said for Tomcat: just get the latest point-release in the recommended
> branch.
> 
> If you are using mod_jk, always get the latest version. Never install
> mod_jk2 -- it's a dead project and has been (confusingly) replaced by
> mod_jk (which appears to be a version "behind", but is in fact the
> state-of-the-art for AJP connectors).
> 
>> As for newer version of connector, is it possible to use
>> mod_jk-1.2.28-httpd-2.2.3.so?
> 
> It's best to use
> mod-jk-[mod_jk version]-httpd-[matching-httpd-version].so
> 
> If you use httpd 2.2.13 and mod_jk-xyz-httpd-2.2.3.so, you may encounter
> problems.
> 
> Actually, it's best to download the source code for mod_jk and build it
> against your exact httpd version if that's a possibility for you.
> Compiling mod_jk is trivial.
> 
>> It is an .so file, while I plan to deploy the
>> Tomcat and Apache in Windows. On the other hand, I cannot find
>> mod_jk-1.2.28-httpd-2.2.3.dll. There are other .dll files, but those are
>> for
>> IIS, while I plan to use Tomcat with Apache on Windows.
> 
> Yeah, the files in
> http://mirrors.devlib.org/apache/tomcat/tomcat-connectors/jk/binaries/win32/jk-1.2.28/
> are called .so but they are appropriate for deployment on windows.
> 
> - -chris
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (MingW32)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAkrGLj8ACgkQ9CaO5/Lv0PA0MwCfWunvgH+z65T+2wC4zgQ0RD2s
> BIAAoLoBrFYVnYBqw7KzQozEf9b/dlWz
> =j57F
> -----END PGP SIGNATURE-----
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Installing-Tomcat%3A-how-much-do-versions-matter--tp25696421p25725896.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message