tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <billwbar...@verizon.net>
Subject Re: jsvc will not start on Snow Leopard & Tomcat 6
Date Fri, 04 Sep 2009 01:57:00 GMT
There is a patch in https://issues.apache.org/jira/browse/DAEMON-98, but I 
don't know if is the same issue.  There are a couple of other OS/X related 
issues there as well.

"bemaniac" <adam@startforce.com> wrote in message 
news:25285131.post@talk.nabble.com...
>
>
> I tried running ldd, but I guess that command doesn't exist in OS X Snow
> Leopard. Is there another command I can try?
>
> I've looked in the directory it is looking in to find 
> "libjvm_compat.dylib",
> and the only thing similar that's in there is "libjvm.dylib".
>

It doesn't really matter, since jsvc dynamically loads the libjvm, so it 
wouldn't show up anyway.  Probably the best thing to do is to try and run 
jsvc with the -debug flag and post the resulting output.

If you are feeling like hacking around yourself, the reference to 
libjvm_campat.dylib is at line 142 of java.c.
>
>
> Christopher Schultz-2 wrote:
>>
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>> bemaniac,
>>
>> On 9/3/2009 12:48 PM, bemaniac wrote:
>>> When I install jsvc, even
>>> though it appears to compile properly, it always fails to start. When I
>>> check the catalina.out log, it gives the following message:
>>>
>>> 02/09/2009 16:46:42 30987 jsvc error: Cannot load required shell library
>>> /Library/Java/Home/../Libraries/libjvm_compat.dylib
>>> 02/09/2009 16:46:42 30986 jsvc error: Service exit with a return value 
>>> of
>>> 1
>>>
>>> Looking in my frameworks, it looks like "libjvm_compat.dylib" doesn't
>>> exist,
>>> but "libjvm.dylib" does exist, though I'm not sure if that's what it
>>> should
>>> be looking for.
>>
>> Hmm. I wonder how you were able to link against libjvm_compat.dylib
>> during compilation. I wonder if your Java install is no longer sane.
>> What version are you running?
>>
>> What do you get when you run:
>>
>> $ ldd jsvc
>>
>> ?
>>
>> If libjvm_compat.dylib isn't listed there, try:
>> $ ldd -v jsvc
>>
>> ...and see which library jsvc uses that uses libjvm_compat.dylib
>>
>> Hope that helps,
>> - -chris
>> -----BEGIN PGP SIGNATURE-----
>> Version: GnuPG v1.4.9 (MingW32)
>> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>>
>> iEYEARECAAYFAkqgP+0ACgkQ9CaO5/Lv0PBAswCguIwWgZh/zzfXS+yKcsgEHP23
>> fQcAn1AE1ap8EO1UHAzvLtiOG2bx/7eE
>> =D/Hj
>> -----END PGP SIGNATURE-----
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>>
>
> -- 
> View this message in context: 
> http://www.nabble.com/jsvc-will-not-start-on-Snow-Leopard---Tomcat-6-tp25279897p25285131.html
> Sent from the Tomcat - User mailing list archive at Nabble.com. 




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message