tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Unable to Access Servlet After Migrating From Tomcat 5.0.25 to 6.0.18
Date Fri, 04 Sep 2009 13:50:57 GMT
> From: Lataxes, Karl [mailto:Karl.Lataxes@nielsen.com]
> Subject: RE: Unable to Access Servlet After Migrating From Tomcat
> 5.0.25 to 6.0.18
> 
> I made the recommended changes but am still getting the exception.  The
> context file that I renamed to UMI.xml contains only the following:
> 
> <Context  docBase="/amd/homes/lataxeks/umi/ap/DataColl"
> 	reloadable="true">
> </Context>

Does that docBase actually exist?  Does that path consist of hard links only?  If any symlinks
are involved, you will need to set allowLinking="true" in the <Context>.

> Context still is being loaded at startup, so that is not the issue.

Post the log for that, please.

> <servlet-mapping>
> 	<servlet-name>HUControlServlet</servlet-name>
> 	<url-pattern>/servlet/HUControlServlet</url-pattern>
> </servlet-mapping>
> 
> I also tried removing the "/" from the beginning of the url-pattern
> parameter and restarted Tomcat, but the results were the same.

Read the servlet spec; the leading slash is required.

What exact URL are you using?

Should probably post your complete web.xml again.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message