tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: tomcat6 + apache 2.2 mod_jk - Help
Date Fri, 18 Sep 2009 23:02:08 GMT
On 18.09.2009 19:29, Paul S wrote:
> I have installed mod_jk 1.2.28 and have tomcat 6 installed on linux.
> 
> i created worker.prop file under apache2. 
> 
> workers.properties
> -----------------
> worker.list=wkr01
> worker.wkr01.type=ajp13
> worker.wkr01.host=localhost
> worker.wkr01.port=8009
> 
> httpd.conf
> -----------
> Include "/usr/local/apache2/conf/mod_jk.conf"
> 
> mod_jk.conf
> -----------
> LoadModule jk_module modules/mod_jk.so
>  JkShmFile /usr/local/apache2/logs/jk-runtime-status
>   JkLogFile /usr/local/apache2/logs/mod_jk.log
>   JkLogLevel debug
>   JkWorkersFile /usr/local/apache2/conf/workers.properties
>   JkMount /helloWorld wkr01
> <VirtualHost *:80>
>    JkMount /helloWorld wkr01
> </VirtualHost>
> 
> 
> i have Connector entry in server.xml on tomcat as.
> server.xml
> -----------
> <Connector port="8009" enableLookups="false" protocol="AJP/1.3" redirectPort="8445"
debug="1" />
> 
> 
> Apache is running on port 8079.
> tomcat is running on 8080
> 
> 
> i have helloWorld  webapp installed on tomcat under webapps.
> 
> 
> i am able to access helloWorld using tomcat:   http://localhost:8080/helloWorld
> I am able to access apache: http://localhost   ---> i see 'It works' page come up.
> 
> When i try to access 
> http://localhost:8079/helloWorld i am getting this error....
> 
> 
> 
> ...
> ..
>  init_jk::mod_jk.c (3183): mod_jk/1.2.28 initialized
> ...
> ...
>  ajp_get_endpoint::jk_ajp_common.c (2977): acquired connection pool slot=0 after 0 retries
> ajp_marshal_into_msgb::jk_ajp_common.c (605): ajp marshaling done
> ajp_service::jk_ajp_common.c (2283): processing wkr01 with 2 retries
> ajp_send_request::jk_ajp_common.c (1501): (wkr01) all endpoints are disconnected.
> jk_open_socket::jk_connect.c (452): socket TCP_NODELAY set to On
> jk_open_socket::jk_connect.c (541): timeout 300 set for socket=13
> jk_open_socket::jk_connect.c (576): trying to connect socket 13 to 127.0.0.1:8009
> jk_open_socket::jk_connect.c (594): connect to 127.0.0.1:8009 failed (errno=111)
> ajp_connect_to_endpoint::jk_ajp_common.c (922): Failed opening socket to (127.0.0.1:8009)
(errno=111)
> ajp_send_request::jk_ajp_common.c (1507): (wkr01) connecting to backend failed. Tomcat
is probably not started or is listening on the wrong port (errno=111)
> ajp_service::jk_ajp_common.c (2447): (wkr01) sending request to tomcat failed (recoverable),
because of error during request sending (attempt=1)
> ajp_service::jk_ajp_common.c (2304): retry 1, sleeping for 100 ms before retrying
> 
> 
> Am i missing any configuration?

Use netstat to check, whether something is actually listening on port
8009 for * or 127.0.0.1. errno 111 is connection refused, so 127.0.0.1
in your case responds with the info, that nothing is listening on port 8009.

Regards,

Rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message