tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David kerber <dcker...@verizon.net>
Subject Re: Configuring second tomcat instance on same box
Date Thu, 17 Sep 2009 15:38:26 GMT
It looks like you may have missed the shutdown port.


Nagulapalli, Srinivas wrote:
> I am trying to create second Tomcat instance on same machine.
> Installed Tomcat into separate folder say c:\tomcat2 and changed
> the conf/server.xml port numbers to different values.
> Basically I bumped the Server port from 8005 to 8006,
> connector port to 8081 from 8080 and redirectPort to 8444 (from 8443).
> Changes are like below.
> 
> Still, when I start this second instance, I get the error saying:
> "Several ports (8005,8009) required by Tomcat at localhost are already
> in use."
> 
> True, they are in use as my original Tomcat instance is running on them.
> But I changed those port numbers for this instance in server.xml file.
> Do I have to change else where? Thanks much for insights and pointers.
> 
> Best
> Srini
> 
> ==Snippets from TOMCAT2_HOME\conf\server.xml============
> 
> <?xml version='1.0' encoding='utf-8'?>
> <Server port="8006" shutdown="SHUTDOWN"> <!-- was 8005 originally -->
> .....
>     <!-- was originally at 8080, 8443 -->
>     <Connector port="8081" protocol="HTTP/1.1" 
>                connectionTimeout="20000" 
>                redirectPort="8444" />
> 
>     <!-- Define an AJP 1.3 Connector on port 8010(was 8009!) -->
>     <Connector port="8010" protocol="AJP/1.3" redirectPort="8444" /> 
>     <!-- In above ports were 8009 and 8443 respectively, originally! -->
>        .....
>       </Host>
>     </Engine>
>   </Service>
> </Server>



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message