tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Unable to Access Servlet After Migrating From Tomcat 5.0.25 to 6.0.18
Date Fri, 04 Sep 2009 15:59:46 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Karl,

On 9/4/2009 11:10 AM, Lataxes, Karl wrote:
> I tried your suggestion and replaced the trailing / in the url-pattern
> of the servlet-mapping tag with *, but got the same result.  I even
> tried commenting out servlet-mapping altogether, but still received the
> file not found exception.

Chuck was right on both counts: remove the leading /UMI, and fix the
trailing asterisk to include a /. So, the mapping uri would need to be:

<url-pattern>/servlet/HUControlServlet/*</url-pattern>

> The HUSim class is part of an application that I wrote years back to
> test servlet functionality, and it has worked up to and including
> servlet deployment in 5.0.25.  I removed the trailing /, rebuilt the
> application, and ran it again, with the same result.  I strongly believe
> it may be a mapping issue, but I just can't seem to nail it down.

Go ahead and re-post your entire conf/Catalina/localhost/UMI.xml and
web.xml from your webapp.

Also, it wouldn't hurt to stop Tomcat, remove the entire 'work'
directory from CATALINA_BASE (the root of the Tomcat install), and
re-start Tomcat, just in case something is being inadvertently cached in
there.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkqhOXIACgkQ9CaO5/Lv0PAv5wCdFFcgXjtr836UYd251fNAy2GZ
8ngAn0FdAlstoJ2Z5yLq12lM8LL7iDbX
=EoZC
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message