tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jamez smith <jamez...@gmail.com>
Subject Re: tomcat 4.1.31 problem
Date Thu, 03 Sep 2009 02:08:22 GMT
Hi Mark,

Tomcat is only used for local development environment.  In our production,
we use Websphere application server on AIX.  I am also new to this project
and was told I can only use Tomcat 4.1 to setup my local development.

I like to clarify that the JVM 1.4 is no longer supported by Sun?

Thanks,
Jamez.

On Wed, Sep 2, 2009 at 9:52 PM, Mark Thomas <markt@apache.org> wrote:

> jamez smith wrote:
> >> Good day Chunk,
> >>
> >
> >>>> Have you actually tried compiling under 1.5 or 1.6?  You might be
> >> surprised at how few problems there are.
> >>
> >> I could try to compile under 1.5.  But I dare not to use it in
> production
> >> box, as this project is well controlled by the company.  Every step I do
> >> need to be documented. I have no right to change the fundamental
> framework
> >> or JDK at all. :-(
>
> Here are a few arguments for upgrading the JVM and Tomcat
> - the JVM is no longer supported by Sun
> - the major Tomcat version (4.1.x) is no longer supported by the ASF
> - the minor Tomcat version (4.1.31) has 9 important, 2 moderate and 16
> known, published security vulnerabilities.
>
> If an application is so critical it has to be that tightly controlled, I
> have to wonder why that many security vulnerabilities are not a concern.
>  Can it really be the case that none of them apply in your environment?
>
> Mark
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message