tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bradley Wagner <bradley.wag...@hannonhill.com>
Subject Re: 100% usage and hanging on startup of Spring/Hibernate app in Tomcat 5.5 on Ubuntu 7
Date Thu, 03 Sep 2009 20:26:35 GMT
Ok, I'll try that next. Two things:
- Did some searching, but couldn't find how to determine the default GC
method for my Java version
- Would you recommend I move this problem elsewhere, given that this is
likely not related to Tomcat at all. I don't want to spam this list.

Thanks,
Bradley

On Thu, Sep 3, 2009 at 4:24 PM, Caldarale, Charles R <
Chuck.Caldarale@unisys.com> wrote:

> > From: Bradley Wagner [mailto:bradley.wagner@hannonhill.com]
> > Subject: Re: 100% usage and hanging on startup of Spring/Hibernate app
> > in Tomcat 5.5 on Ubuntu 7
> >
> > And again in a new place on subsequent attempt.
>
> There's nothing unusual that I can see in the traces, so it looks like you
> will have to try random GC settings until something works (as Mark suggested
> some time ago).  Try turning these tags on, one at a time:
>
> -XX:+UseParallelGC
> -XX:+UseParallelOldGC
> -XX:+UseSerialGC
> -XX:+DoEscapeAnalysis
> -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC
>
> The last one is somewhat experimental, as the parameter implies.
>
>  - Chuck
>
>
> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
> MATERIAL and is thus for use only by the intended recipient. If you received
> this in error, please contact the sender and delete the e-mail and its
> attachments from all computers.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message