tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joseph2009 <nelbyjos...@gmail.com>
Subject mod_jk Tomcat AJP Connectivity problem
Date Sat, 05 Sep 2009 09:02:28 GMT

I am using Tomcat 5.5.20 and Apache 2.2 with Mod_jk 1.2.2.7 on Solaris 10
intel platform. Following is my configurations

Tomcat

        port="8030"
        enableLookups="false"
        redirectPort="8444"
        protocol="AJP/1.3"
        compression="on"
        compressableMimeType="text/html,text/xml,text/css,text/javascript"
        maxThreads="250"
        maxSpareThreads="75"
        minSpareThreads="25"
        connectionTimeout="600000"

Apache

<IfModule mpm_prefork_module>
    StartServers         10
    MinSpareServers      10
    MaxSpareServers      20
    MaxClients          200
    MaxRequestsPerChild   0
</IfModule>

mod_jk
worker.template.type=ajp13
worker.template.lbfactor=1
worker.template.ping_timeout=1000
worker.template.ping_mode=A
worker.template.socket_timeout=10
worker.template.connection_pool_timeout=600
worker.anznz.reference=worker.template
worker.anznz.host=localhost
worker.anznz.port=8030

My website is running fine for the entire day and mod_jk started throwing
the following error end of the day

[Sat Sep 05 11:27:05 2009][23566:1] [error] jk_ajp_common.c (2400): (xxxx)
sending request to tomcat failed (unrecoverable),  (attempt=1)

[Sat Sep 05 11:27:04 2009][7724:1] [info] jk_ajp_common.c (1104): (xxxx)
can't receive the response message from tomcat, tomcat (127.0.0.1:8030) has
forceda connection close for socket 36

[Sat Sep 05 11:27:05 2009][7724:1] [error] jk_ajp_common.c (1920): (xxxx)
Tomcat is down or refused connection. No response has been sent to the
client (yet
)

Once the abouve error hits, the user get the service not available pages. It
is not happening to all users. Then when I restart the Tomcat, it started
working. There is no problem in accessing the site through the HTTP
connector in the Tomcat.

Did someone experience similar problem and is there any solution for this
problem?

Thanks in advance
-- 
View this message in context: http://www.nabble.com/mod_jk-Tomcat-AJP-Connectivity-problem-tp25306341p25306341.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message