tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From veerabahu <moonpearl_vegtime_2...@yahoo.com>
Subject EL expressions not evaluation in tag library
Date Wed, 02 Sep 2009 09:03:28 GMT


Hi All, 

We are using EL expression in one of our tag libraries (.tag files), like {
	<input type="text" id="${id}">
}

1. Made sure that servlets 2.4 is enabled in webapp web.xml like 
{
	<?xml version="1.0" encoding="UTF-8"?> 
	<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="2.4"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
	…
	…
	</web-app>
}

2. Following jars are available in WEB-INF/lib (in addition to other
standard jars)
	1. javaee.jar
	2. standard.jar
	3. jstl.jar
	4. struts-el-1.2.4.jar

Now, when we use EL in my JSP it is getting evaluated and able to see proper
result. But the EL in tag libraries (as shown above) are not getting
executed. 

We are using Tomcat 5.5 with Java1.5. There is more than one webapp running
under same tomcat. All other webapps runs with servlets specification 2.3 (
I mean different DOCTYPE in web.xml)

Can you help in identifying the reason for EL not getting executed ONLY in
tag libraries?

Thanks,
Veerabahu 

-- 
View this message in context: http://www.nabble.com/EL-expressions-not-evaluation-in-tag-library-tp25254057p25254057.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message