tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From netsick <kris.gl...@virginblue.com.au>
Subject Re: AJP connections just stop working
Date Wed, 02 Sep 2009 03:22:12 GMT

Hi,

How did the results of your monitoring go ? Were you connection/keepalive
timeouts helping ? Are they still set at 10mins ?

Please outline the steps you made if the problem has indeed been resolved.

Thanks
Kris


Guy Cube wrote:
> 
> Here are my updates :
> 
> Interesting finding is whatever AJP connectors stuck in Keepalive mode for
> long time are for requests coming from remote clients. All connections for
> requests  coming from local (internal network) clients were changed to
> CLOSE_WAIT after some time. 
> 
> Today I tried with  keepAliveTimeout and connectionTimeout setting at
> server.xml 
> 
> 
>  <Connector port="8009" address="${jboss.bind.address}" protocol="AJP/1.3"
>          emptySessionPath="true" enableLookups="false" redirectPort="8443" 
>          connectionTimeout="300000"   keepAliveTimeout="300000" />
> 
> I monitored from both JBoss JMX console and netstat. Connectors at JMX
> console  stayed at stage 6 (STAGE_KEEPALIVE) for 5 minutes and changed to
> stage 7 (STAGE_ENDED  ) after keep alive timeout (5 minutes). But  in
> netstat it is still shown up as follows:
> 
>  netstat -aonp | grep 8009
> 
> tcp        0      0 0.0.0.0:8009               0.0.0.0:*                  
> LISTEN      5229/java           off (0.00/0/0)
> tcp        0      0 xx.xx.xx.xxx:8009        yy.yy.yyy.yyy:49771         
> ESTABLISHED 25229/java           off (0.00/0/0)
> tcp        0      0 xx.xx.xx.xxx:8009        yy.yy.yyy.yyy:49768         
> ESTABLISHED 25229/java           off (0.00/0/0)
> tcp        0      0 xx.xx.xx.xxx:8009        yy.yy.yyy.yyy:49767         
> ESTABLISHED 25229/java           off (0.00/0/0)
> tcp        0      0 xx.xx.xx.xxx:8009        yy.yy.yyy.yyy:49766         
> ESTABLISHED 25229/java           off (0.00/0/0)
> tcp        0      0 xx.xx.xx.xxx:8009        yy.yy.yyy.yyy:49765         
> ESTABLISHED 25229/java           off (0.00/0/0)
> 
> pid 25229 is process id of JBoss. I am running JBoss on CentOS 5.2, Kernel
> 2.6.18-.
> 
> I will be monitoring the outcomes tonight.
> 
> Regards,
> GC
> 
> 
> 
> 
> kvancamp wrote:
>> 
>> 
>> Guy Cube wrote:
>>> 
>>> Hello,
>>> 
>>> We are also haveing exact same issue in our environment. We are using
>>> JBoss 4.2.3, Apache 2.2.11 with mod_proxy_ajp using ajp to connect
>>> between Apache and JBoss. It happens intermittently and when i happnes
>>> all AJP's TCP connections are stayed in ESTABLISHED state on JBoss
>>> machine. In thread dump, all AJP threads are in waiting state. 
>>> 
>>> Anyone found solution or work around for this issue?
>>> 
>>> Thanks,
>>> GC
>>> 
>> 
>> For now I have set the connectionTimeout to 10 minutes on my AJP
>> connection, e.g.
>>     <!-- Define an AJP 1.3 Connector on port 8009, timeout in 10 mins.
>> -->
>>     <Connector port="8009" address="${jboss.bind.address}"
>> protocol="AJP/1.3"
>>          emptySessionPath="true" enableLookups="false"
>> redirectPort="8443"
>>          connectionTimeout="600000"
>>     />
>> 
>> I am monitoring results, it is too soon to tell if this alone will solve
>> the problem or if I also have to delve into my firewall (I was incorrect
>> in my original response above - there IS a firewall between my IIS proxy
>> and my JBoss server, and it has a 1 hour idle tcp session timeout), or my
>> IIS proxy (which is configured with a 5-minute socket timeout).
>> 
>> Ken
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/AJP-connections-just-stop-working-tp1118618p25251096.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message