tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl" <c...@etrak-plus.com>
Subject Re: Not compiling JSP's
Date Wed, 02 Sep 2009 12:09:25 GMT
Ron,

Thanks for your reply.

The 'one hour off' problem was an install issue by the guy who brought up 
that server... wait a minute, that was me.

The mystery is that Tomcat will compile some JSP's just fine but will always 
stop on the same ones.  On the theory it was memory, I changed the Java 
memory options to match the current production server... no joy there.  To 
test the theory the problrm was the last date modified, I made certain the 
dates on all JSP's were one day before the server date (note that the dates 
on the JSP's that compiled were within seconds of those that didn't)... no 
joy here either.  If I copy .java files from development to server, the 
server will actually remove the .java files from the work directory so no 
joy there.  If I copy the .java and .class files from the development build 
directory to the work directory on the server, that appeared to work at one 
point but now the server removes those files from the work directory.  The 
JSP's that the server fails on are no larger nor no more complex than those 
it compiles.

I am bringing Netbeans up on the server so I can step through what's 
happening but have not yet got that running.

Thanks,

Carl

----- Original Message ----- 
From: "Ron McNulty" <rmcnulty@xtra.co.nz>
To: "Tomcat Users List" <users@tomcat.apache.org>
Sent: Wednesday, September 02, 2009 3:04 AM
Subject: Re: Not compiling JSP's


> Hi Carl
>
> I've seen problems like this when deploying across time zones (in my case 
> NZ -> San Francisco), especially if there is a Windows box in the 
> equation. The "1 hour off" sounds odd - daylight saving problem?
>
> Regards
>
> Ron
>
> ----- Original Message ----- 
> From: "Carl" <carl@etrak-plus.com>
> To: "Tomcat Users List" <users@tomcat.apache.org>
> Sent: Wednesday, September 02, 2009 1:12 AM
> Subject: Re: Not compiling JSP's
>
>
>> Mark,
>>
>> Thanks for your reply.
>>
>> I checked the modification times and they are all yesterday while the 
>> system date/time on the server is today (although it was one hour off.)
>>
>> I am presently bringing Netbeans up on the test server in an attempt to 
>> see what is happening.
>>
>> If you have any other suggestions, I am all ears.
>>
>> Carl
>>
>>
>> ----- Original Message ----- 
>> From: "Mark Thomas" <markt@apache.org>
>> To: "Tomcat Users List" <users@tomcat.apache.org>
>> Sent: Tuesday, September 01, 2009 3:14 AM
>> Subject: Re: Not compiling JSP's
>>
>>
>>> Carl wrote:
>>>> Odd that some JSP's get compiled and some won't.  Note that it is 
>>>> always
>>>> the same JSP's that will not compile.
>>>
>>> File modification times in the future on the JSPs?
>>>
>>> One way to find out what is going on is to use remote debugging and your
>>> favourite IDE to step through the JSP compilation process and see why it
>>> isn't working.
>>>
>>> Mark
>>>
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message