tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tena Sakai" <tsa...@gallo.ucsf.edu>
Subject (newbie question) missing classs file?
Date Tue, 18 Aug 2009 18:48:45 GMT
Hi,

I am new to tomcat and jsp.  I appologize in advance my lack of knowledge,
but I would appreciate some poninters.

I am running tomcat 6.0.14 on redhat linux.

After reading a few pages of documentation, I tried: http://localhost:8080/sample

It rendered what's in $CATALINA_HOME/webapps/sample/index.html,
which included 2 hyperlinks: "JSP page" and "servlet".  Both
links worked fine.

Then I found a file $CATALINA_HOME/webapps/sample/WEB-INF/classes/mypackage/Hello.class.
I removed this class file and hit the same url as before (http://localhost:8080/sample),
and each of the "JSP page" and "servlet", expecting the error from tomcat.

To my amazement, they both worked.

Question number 1: Where is the executable class file?

Then I went on to modify hello.jsp in $CATALINA_HOME/webapps/sample directory.
I added extra string "Hello!" to what used to be:
<%= new String("Hello!") %>

Tomcat gave me what I expected: double Hello's.
I thought it might have generated a class file.  But there is no class file
anywhere under $CATALINA_HOME/webapps/sample directory?

Question number 2: Why does this work?

Thank you in advance.

Regards,

Tena Sakai
tsakai@gallo.ucsf.edu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message