tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Christopher <dchristop...@pixion.com>
Subject /context not working -- mod_jk error: no match for /server-status
Date Thu, 27 Aug 2009 13:45:26 GMT
environment: Tomcat 6.0.18 under apache2 on Mac OS X Server 10.5  
(Leopard).

I am using a mod_jk connector with JBoss.

I am having trouble getting context urls of the form website.my.com/ 
myapplication honoured (or even localhost/myapplication).
(Safari:File not found).I have googled  the error messages below but  
can't find anything applicable to my setup.

The quick start guide at

http://tomcat.apache.org/connectors-doc/generic_howto/quick.html

gives a simple proof of concept for a connector setup (/examples").  
However, this does not work,
though I have followed the editing of the configuration files exactly  
(using JKMount in the httpd.conf etc)

I get an error in mod_jk.log (set to debug level):

[Tue Aug 25 12:41:11.783 2009] [211:2688784416] [debug]  
map_uri_to_worker_ext::jk_uri_worker_map.c (1036): (TEST) Attempting  
to map URI '/server-status' from 5 maps
[Tue Aug 25 12:41:11.783 2009] [211:2688784416] [debug]  
map_uri_to_worker_ext::jk_uri_worker_map.c (1039): Initial match  
value:for URI '/server-status' is -1.
[Tue Aug 25 12:41:11.783 2009] [211:2688784416] [debug]  
find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/ 
examples/*=JBoss1' source 'JkMount'
[Tue Aug 25 12:41:11.783 2009] [211:2688784416] [debug]  
find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/ 
servlet/*=JBoss1' source 'JkMount'
[Tue Aug 25 12:41:11.783 2009] [211:2688784416] [debug]  
find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/ 
sample/*=JBoss1' source 'JkMount'
[Tue Aug 25 12:41:11.784 2009] [211:2688784416] [debug]  
find_match::jk_uri_worker_map.c (850): Attempting to map context URI '/ 
*.jsp=JBoss1' source 'JkMount'
[Tue Aug 25 12:41:11.784 2009] [211:2688784416] [debug]  
map_uri_to_worker_ext::jk_uri_worker_map.c (1047): Match value:for URI  
'/server-status' is -1.
[Tue Aug 25 12:41:11.784 2009] [211:2688784416] [debug]  
jk_translate::mod_jk.c (3536): no match for /server-status found

Any help on how to diagnose what the seeming error is pointing to  
would be much appreciated.

Dennis Christopher
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message