tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohamed Shah <Mohamed.S...@tecnotree.com>
Subject Listener Start Error
Date Thu, 13 Aug 2009 08:00:46 GMT
Hi,

I am getting a Listener Start Error during deployment.

This is the error in log.

Aug 13, 2009 7:26:37 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 53316 ms
Aug 13, 2009 7:27:37 AM org.apache.catalina.startup.HostConfig checkResources
INFO: Undeploying context [/ViewAdjustmentsN]
Aug 13, 2009 7:27:40 AM org.apache.catalina.core.StandardContext addApplicationListener
INFO: The listener "com.liferay.portal.kernel.servlet.PortletContextListener" is already configured
for this context. The duplicate definition has been ignored.
Aug 13, 2009 7:27:40 AM org.apache.catalina.core.StandardContext start
SEVERE: ERROR LISTENERSTART
Aug 13, 2009 7:27:40 AM org.apache.catalina.core.StandardContext start
SEVERE: Context [/ViewAdjustmentsN] startup failed due to previous errors.


Contents web.xml

?xml version="1.0" encoding="UTF-8"?>
<web-app>
	<display-name>ViewAdjustmentsN</display-name>
	 <context-param>
       <param-name>javax.servlet.jsp.jstl.fmt.localizationContext</param-name>
       <param-value>com.liferay.ViewAdjustments.util.ApplicationResources</param-value>
     </context-param>
	<listener>
		<listener-class>com.liferay.portal.kernel.servlet.PortletContextListener</listener-class>
	</listener>
	<servlet>
		<servlet-name>1</servlet-name>
		<servlet-class>com.liferay.portal.kernel.servlet.PortletServlet</servlet-class>
		<init-param>
			<param-name>portlet-class</param-name>
			<param-value>com.liferay.ViewAdjustments.portlet.ViewAdjustmentsPortlet</param-value>
		</init-param>
		<load-on-startup>0</load-on-startup>
	</servlet>
	<servlet-mapping>
		<servlet-name>1</servlet-name>
		<url-pattern>/1/*</url-pattern>
	</servlet-mapping>
	<taglib>
		<taglib-uri>http://java.sun.com/portlet_2_0</taglib-uri>
		<taglib-location>/WEB-INF/tld/liferay-portlet.tld</taglib-location>
	</taglib>
</web-app>


I have Restarted Tomcat . Taken the Listener tags and ran without the listener tags. 
Every time the same error Turns up. May I Know what causes this error as my build is fine.


Thanks & Regards,
Mohamed Shah.K

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message