tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ognjen Blagojevic <ogn...@etf.bg.ac.rs>
Subject Re: TR: pb redeploy with Tomcat 5.5.24
Date Tue, 11 Aug 2009 14:52:18 GMT
Hi,

1. What is the exact error being thrown? (copy paste the stack trace, if 
any)

2. Are you using Tomcat 5.5.23? Can you switch to fresh version of 
tomcat (6.0.20)? It is probably more stable and with less bugs. If you 
can't reproduce the problem on the latest version, that probably means 
that the bug is fixed, and that developers shouldn't spend time on it 
any more. BTW, you are mentioning version 5.5.4. That version does not 
exists. Latest version from 5.5 branch is 5.5.27.

3. What operating system are you using? If you are using windows, please 
take a look at

   http://tomcat.apache.org/tomcat-5.5-doc/config/context.html

search for "antiJARLocking" and "antiResourceLocking" parameters.

Regards,
Ognjen



support-disserto wrote:
> ---------------------------------------------------------------<English
> version>--------------------------------------------------------------------
> ----------------
> 
>  
> 
> Hello,
> 
>  
> 
> I encounter a problem when I redeploy my WAR with Tomcat.
> 
> One of the used libraries throws an error when I try to redeploy my WAR.
> 
> For information, I don’t have the sources of this library.
> 
>  
> 
> To around that I have to stop and start again Tomcat.
> 
> That’s very strange because I have no problem with Tomcat 5.0 or Tomcat
> 5.5.4.
> 
> The file server.xml is the same for Tomcat 5.5.4 and Tomcat 5.5.23.
> 
>  
> 
> I don’t understand why there is a difference between redeploy a WAR with
> Tomcat 5.5.4 and Tomcat 5.5.23. Is somebody having an explanation?
> 
> Moreover can somebody explain to me what’s happens when Tomcat redeploys a
> WAR?
> 
>  
> 
> Thanks in advanced for your help.
> 
>  
> 
> Best regards,
> 
> J. MEVEL
> 
>  
> 
> -----------------------------------------------------------------<Version
> française
>> ---------------------------------------------------------------------------
> ------------
> 
> Bonjour,
> 
>  
> 
> J’ai un souci quand j’essaie de redéployer mon WAR avec Tomcat 5.5.23.
> 
> Un message d’erreur propre à une des librairies que j’utilise et dont je
> n’ai pas le code source, s’affiche quand je fais un redeploy de mon WAR avec
> Tomcat 5.5.23.
> 
>  
> 
> Du coup je suis obligée d’arrêter Tomcat et de le redémarrer pour que mon
> WAR se déploie correctement.
> 
> Par contre je n’ai aucun problème avec Tomcat 5.0 ou Tomcat 5.5.4.
> 
> Le server.xml de Tomcat 5.5.23 est le même que celui de Tomcat 5.5.4. 
> 
>  
> 
> Est-ce que quelqu’un aurait une idée sur l’origine du problème car je suis à
> court d’idée ?
> 
> Que ce passe-t-il quand Tomcat redéploye un WAR ?
> 
> Qu’y a-t-il comme différence entre Tomcat 5.5.4 et Tomcat 5.5.23 qui
> pourrait expliquer ce comportement différent ?
> 
>  
> 
> Merci par avance pour votre aide.
> 
>  
> 
> Cordialement,
> 
> J. MEVEL
> 
>  
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message