tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniele Development-ML <daniele....@googlemail.com>
Subject Installing SSL connector for Tomcat on Linux/Debian
Date Tue, 18 Aug 2009 18:01:25 GMT
Hello everybody,

I'm trying to set up a SSL transport layer, but I'm coming up against some
difficulties.

Specifically, I followed all the steps requires and specified as in the
Tomcat guide - adding some suggestions I found around on several web site
for the installation of APR libraries - but still it doesn't work.

I'm using Tomcat 6.0.20 with the last version of APR library, on a
Lenny/Debian distribution.

The output I get in catalina.out is:

18-Aug-2009 18:05:55 org.apache.catalina.startup.SetAllPropertiesRule begin
WARNING: [SetAllPropertiesRule]{Server/Service/Connector} Setting property
'clientAuth' to 'false' did not find a matching property.
18-Aug-2009 18:05:55 org.apache.catalina.startup.SetAllPropertiesRule begin
WARNING: [SetAllPropertiesRule]{Server/Service/Connector} Setting property
'SSLEngine' to 'on' did not find a matching property.
18-Aug-2009 18:05:55 org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.16.
18-Aug-2009 18:05:55 org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [true], sendfile [true], accept filters
[false], random [true].
18-Aug-2009 18:05:55 org.apache.catalina.core.AprLifecycleListener
lifecycleEvent
INFO: Failed to initialize the SSLEngine.
18-Aug-2009 18:05:55 org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
18-Aug-2009 18:05:55 org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8443
18-Aug-2009 18:05:55 org.apache.coyote.ajp.AjpAprProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
18-Aug-2009 18:05:55 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 656 ms

While my server configuration is:

<!-- Define a SSL HTTP/1.1 Connector on port 8443 -->
<Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
maxThreads="150" scheme="https" secure="true" clientAuth="false"
sslProtocol="TLS" enableLookups="false" disableUploadTimeout="true"
SSLEngine="on"
SSLCertificateFile="${catalina.base}/config/certs/self-signed-cert.pem"
SSLCertificateKeyFile="${catalina.base}/config/certs/rsa-private-key.pem"/>

Where the certificates where generated with OpenSLL on a Windows Platform.

In addition, I included the following lines at the beginning of setclass
file

CATALINA_OPTS="$CATALINA_OPTS
-Djava.library.path=/home/daniele/tomcat-6.0.20/bin/tomcat-native-1.1.16-src/jni/native/.libs"

Where the APR libraries are deposed after the installation.

Any hints or suggestions?

Daniele

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message