tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Tomcat 6.0.18 with SSL and VMWare
Date Mon, 17 Aug 2009 13:08:01 GMT
> From: Sergio Arrighi [mailto:sergio.arrighi@iminholding.com]
> Subject: Tomcat 6.0.18 with SSL and VMWare
> 
>     <Connector port="80" protocol="HTTP/1.1"
>                connectionTimeout="20000"
>                redirectPort="8443" />
> 
>     <Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
>                maxThreads="150" scheme="https" secure="true"
>                clientAuth="false" sslProtocol="TLS"
> keystoreFile=".keystore" />
> 
>     <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />

Since you have the HTTP port defined as 80, you most likely want the HTTPS port on 443, not
8443.

You're missing the keyStorePass attribute on the HTTPS <Connector>.

If you have the APR native library installed, the SSL config is completely different.  Can't
tell you what to look for, since you didn't tell us the guest OS you're using under VMware.

Anything of interest in your logs?

- Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message