tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pierre Goupil <>
Subject Re: Weird Intermittent NoClassDefFound
Date Wed, 29 Jul 2009 11:43:49 GMT

I've never encountered such a situation myself, but it may be because of a
duplicate jar in your classpath. As you may know, looking in WEB-INF/lib
should not be enough.

Maybe you should have a look at this, in order to know where to look :



On Wed, Jul 29, 2009 at 1:39 PM, Chris Masters <> wrote:

> Hi All,
> I'm running tomcat apache-tomcat-6.0.18 with a single application that has
> heavy spring and hibernate usage. One of the deployments mainly deals with
> batch processing from Quartz. After a couple days worth of processing I
> suddenly get NoClassDefFound errors (usually from some random hibernate
> class) for classes that have been previously loaded. The other day it
> occured with a class from JGroups (we use this for clustered cache
> communication) and it spewed out *loads* of NoClassDefFound  and ended up
> filling up the disk.
> So, a couple questions:
>  - has anyone else encountered this?
>  - could this be a tomcat class loader issue?
>  - any ideas? help?
> Thanks in advance,
> rotis23
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

Sans amis était le grand maître des mondes,
Eprouvait manque, ce pour quoi il créa les esprits,
Miroirs bienveillants de sa béatitude.
Mais au vrai, il ne trouva aucun égal,
Du calice du royaume total des âmes
Ecume jusqu'à lui l'infinité.

(Schiller, "l'amitié")

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message