tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid...@pidster.com>
Subject Re: Multiple tomcat instances in linux server
Date Tue, 28 Jul 2009 11:15:39 GMT
On 28/7/09 10:31, given.shirinda@sita.co.za wrote:
> Hi Guyz.
>
>
> I want to run multiple tomcats in my server,I tried the following  tutorials from this
link http://tomcat.apache.org/tomcat-5.5-doc/cluster-howto.html.
>
> I created the following folders
>
> tomcat_instance1
> tomcat_instance2
> tomcat_instance3
>
>
> I  have copied conf/server.xml and web.xml to the above mentioned folder from apache-tomcat-5.5.25.
>
>
> I did export the following Variables,
> CATALINA_HOME=/opt/apache-tomcat-5.5.25
> CATALINA_BASE=/opt/tomcat_instances1
>
> For tomcat_instances1.
> I made this changes
>
> <Server port="8005" shutdown="SHUTDOWN">  to<Server port="8025" shutdown="SHUTDOWN">
> <Connector port="8080" maxHttpHeaderSize="8192"... to<Connector port="8010"
> maxHttpHeaderSize="8192"...
> <Connector port="8009" enableLookups="false" redirectPort="8443" protocol="AJP/1.3"
/>  to
> <Connector port="8019" enableLookups="false" redirectPort="8443" protocol="AJP/1.3"
/>
>
> For tomcat_instances2.
> I made this changes

If you're running multiple Tomcats you also need to change the shutdown 
port number for each one, to make them all unique.

> <Server port="8005" shutdown="SHUTDOWN">  to<Server port="8035" shutdown="SHUTDOWN">
> <Connector port="8080" maxHttpHeaderSize="8192"... to<Connector port="8011"
> maxHttpHeaderSize="8192"...
> <Connector port="8009" enableLookups="false" redirectPort="8443" protocol="AJP/1.3"
/>  to
> <Connector port="8019" enableLookups="false" redirectPort="8443" protocol="AJP/1.3"
/>

So you made the AJP connectors the same?
If you don't need them, just comment them out.

p


> when I start the parent tomcat
>
> /opt/apache-tomcat-5.5.25/bin/.startup.sh
>
> The logs file for this apache-tomcat-5.5.25 is empty
>
> when I type this to browser,
> http://localhost:8080 it says Failed to Connect
>
> when I start the second tomcat ,it worked fine
>
> http://localhost:8010
>
>
> I dont get the point where I missed it.
>
> Feel free to send me the step-by-step installation manuals
> Best Regards
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message