tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: On my Webserver: java.lang.NoClassDefFoundError: javax/servlet/http/HttpServlet
Date Mon, 27 Jul 2009 13:53:33 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Paul,

On 7/26/2009 5:47 AM, Paul van Hoven wrote:
> Yeah, that was it. Thanks for the great help. I deleted gwt-user.jar and
> now it runs perfectly fine.

For a bit of background, the Servlet API classes are supposed to be
located in one place only: in the server's main library directory.
Loading classes from anywhere else could be ... confusing, thus this
prohibition.

The application server is supposed to veto any classes loading from a
webapp's ClassLoader that are defined in certain packages (such as
java.* and javax.* ; see section 9.7.2 of the 2.5 Servlet Spec).

If you try to load servlet-api-x.y.z.jar into Tomcat, it does in fact
veto these classes and tells you about it. I'm not sure why Tomcat would
have a problem with gwt-servlet.jar, honestly, but since it contains the
classes from the Servlet API, at least those classes will be prohibited
from loading.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkptsV0ACgkQ9CaO5/Lv0PAFdwCfZSFk/RibGkW3O3cXfMHi2DJd
a5QAn3MdFN5fgejNGzSbjm4sBmsJ5Iz4
=e5Z/
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message