tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Issues running 2 versions of tomcat?
Date Tue, 21 Jul 2009 16:00:54 GMT
2009/7/21 Security Management <list-subscriptions@secmgmt.com>:
> I have a server, running Tomcat 5 with Java 4, and running Tomcat 6 with
> Java 6.
>
> There is another application that is an XMLRPC server on ports 8085-8100
>
> The XMLRPC service is running on Tomcat 5, and a struts 2 application is
> running on Tomcat 6.
>
> I have verified that there are no common ports listed for the 3 sets of
> ports (2 x server.xml, and the config for the rpc).
>
> Can anyone explain why the 8085-8100 ports might go haywire every now and
> then?  The app works fine with Tomcat 6 shutdown, but when Tomcat 6 starts,
> there are anomalies.  I've verified the correct JVMs are starting the
> correct Tomcat versions, etc.  Anywhere else I might find a clue?
>

1. Please provide your definition of "haywire"

2. Do you have Apache HTTPD in front of Tomcat ?  Do you use mod_jk?

3. Your operating system, and what versions of the mentioned software
you are running.
How old is your Tomcat 5? You may want to look at
http://tomcat.apache.org/security-5.html

Also Java 4 has already reached its EOL.
http://java.sun.com/j2se/1.4.2/download.html

Usually older apps run fine on Java 6, and Tomcat 5 apps run fine when
deployed on Tomcat 6,  and two instances of Tomcat, be them of
different or of the same version, run fine with each other.

4. What do you mean by "8085-8100"


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message