tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <knst.koli...@gmail.com>
Subject Re: Cannot find any information on property 'x' in a bean of type 'bfs.beans.BFSInfo'
Date Thu, 02 Jul 2009 09:29:34 GMT
2009/7/2 Jim Anderson <ezjab@ieee.org>:
> Hi,
>
> I'm running tomcat 6.0.18 on Linux and I'm having a problem running
> a javabean. I created a bean and was able to call setProperty and
> getProperty
> for the property 'startPage' in the bean. When I added a 2nd property
> to the bean, I got the following message:
>
> org.apache.jasper.JasperException: Cannot find any information on property
> 'midContent' in a bean of type 'bfs.beans.BFSInfo'
>
> The setter and getter methods were copied and pasted from 'startPage' so
> they
> should have worked. I checked the spelling of the new property 'midContent'
> VERY
> carefully and I'm sure there was not a spelling error.
>
> I experimented and found that no matter what name I gave the new property,
> it
> would not work with the getter and setter methods. In the jsp code, my
> getter
> and setter methods for 'startPage' continued to work. I decided to rename
> the property to 'sPage'. I did this, recompiled the source, rebuilt the jar
> file
> and placed it the web library. I ran the jsp page again and found that
> getProperty
> on 'sPage' failed, but if I changed 'sPage' back to 'startPage', the jsp
> page
> worked.
>
> It looks like tomcat is still is finding an old jar file or has cached a
> reference
> to the old library.
>

It looks like you have not restarted (reloaded) your web application.

One of the ways to do so in development mode is to touch your
WEB-INF/web.xml  (or any other WatchedResource if those are configured).

Another way is to use the Tomcat Manager web application.
http://tomcat.apache.org/tomcat-6.0-doc/html-manager-howto.html
http://tomcat.apache.org/tomcat-6.0-doc/manager-howto.html


Best regards,
Konstantin Kolinko

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message