tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Janon <fja...@gmail.com>
Subject Tomcat 5.5 on Windows Server 2003, HTTPS and tc-native
Date Fri, 31 Jul 2009 12:38:19 GMT
Hi,

I just want to share my experience installing Tomcat 5.5.23 (and also 5.5.27
from memory) on Windows Server 2003 Datacenter Edition. I installed 5.5.27
on that version of Windows by creating an instance on Amazon EC2. Tomcat
worked pretty quickly on port 80. I needed to enable HTTPS so I copied the
SSL certificate that was used on my development machine, made the proper
changes in the Tomcat config, restarted the server but accessing
https://localhost would hang for a while and then timeout. I questioned
everything: my Tomcat config, my EC2 instance config, my app, my certificate
for almost a week. Searching the Tomcat for "windows HTTPS" mail archive
today gave me a hint to solve the issue. I found and deleted the
"tc-native.dll" file, restarted Tomcat and the HTTPS connection worked
straight away.

I am not a Tomcat expert but I installed it many times (probably over 20
times) on machines running Windows XP Pro and Windows Enterprise and Small
Business Server and I didn't encounter that issue. It might have been a
diffferent version of Tomcat 5.5.x, so I don't know how I didn't hit that
problem before. I want to mention as well that the logs didn't show any
error at all and that Tomcat, mySQL and my app worked great on 3 other
machines with XP Pro and SBS.

Just sharing for the next person banging her/his head...

Fred

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message