tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikos Spanoudakis" <ni...@science.tuc.gr>
Subject RE: Problem with deploying an application
Date Fri, 31 Jul 2009 13:55:32 GMT
Dear Chuck, all,

The problem was resolved by installing the Java 6 JDK on my server.

Thank you,
Nikos

-----Original Message-----
From: Nikos Spanoudakis [mailto:nikos@science.tuc.gr] 
Sent: Tuesday, July 28, 2009 1:31 PM
To: 'Tomcat Users List'
Subject: RE: Problem with deploying an application

Dear Chuck,

Thanks for your quick response, I checked out the points that you made and I
have the following findings:

>From: Caldarale, Charles R [mailto:Chuck.Caldarale@unisys.com]
>
>> From: Nikos Spanoudakis [mailto:nikos@science.tuc.gr]
>> Subject: Problem with deploying an application
>> 
>> I try to deploy an application that executes fine on a linux machine.
>
>Is the Linux system running the same version of Tomcat?

No, the Linux system has the Tomcat 6, however The build is for tomcat 5.5.
The same application has been deployed in a Windows system with Tomcat 5.5.

>You might want to compare Tomcat's common and shared directories on the
SunOS system with those on the Linux box.

They are almost the same, the other system (now I am talking about the
Windows with Tomcat 5.5) has the jasper-compiler-jdt.jar file in Tomcat's
common/lib that is missing in my tomcat installation. Moreover, my
installation has the ant.jar file in the Tomcat's common/lib that is not
present in the Windows with Tomcat 5.5 installation. 

>What's in the WEB-INF/web.xml file for the webapp?

Please find the file attached. Do you see a problem there?

>> java.lang.NoClassDefFoundError:
>> org/apache/commons/io/output/DeferredFileOutputStream

>You are likely missing the commons-io jar.  Since the webapp appears to 
>be
dependent on it, it would normally be located in WEB-INF/lib of the webapp.
However, it may be in another location on the Linux system, such as Tomcat's
>shared/lib or common/lib directories.

The commons-io.jar file is included in the WEB-INF/lib folder of the
application.

>You can also get the same error if you have /two/ copies of the above 
>jar
in one branch of the classloader tree; in this case, you'll need to remove
one of them.

No double files in the application and tomcat common folders. However, the
application has the antlr-2.7.2.jar in the WEB-INF/lib folder while in the
Tomcat's common/lib my installation has the ant.jar file. Could it be a
problem?

> - Chuck

Thank you again, I hope the information above can lead you to another piece
of advice for me...
Nikos



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message