tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikos Spanoudakis" <ni...@science.tuc.gr>
Subject Problem with deploying an application
Date Fri, 24 Jul 2009 15:34:35 GMT
Dear all,

 

I am trying to deploy an application on a Server with the following
Information (as taken from Tomcat Web Application Manager):

 

Tomcat Version: Apache Tomcat/5.5.27

JVM Version: 1.5.0_17-b04

JVM Vendor: Sun Microsystems Inc.

 OS Name: SunOS

OS Version: 5.10

OS Architecture: sparc

 

I try to deploy an application that executes fine on a linux machine.

 

I copy the application in the webapps folder of tomcat in the folder
eprotocol, I start the tomcat service and the url that I put in the browser
is the http://XXX.XXX.XXX.XXX:8080/eprotocol/uLogin.do?do=login (I have put
Xes instead of the IP address of the machine). I get the following error:

 

HTTP Status 404 - Servlet action is not available

 

type Status report

message Servlet action is not available

description The requested resource (Servlet action is not available) is not
available.

 

Apache Tomcat/5.5.27

 

If I try to deploy the war file via the Tomcat Web Application Manager I get
the following error:

 

HTTP Status 500 - 

 

type Exception report

message 

description The server encountered an internal error () that prevented it
from fulfilling this request.

exception 

javax.servlet.ServletException: Servlet execution threw an exception

root cause 

java.lang.NoClassDefFoundError:
org/apache/commons/io/output/DeferredFileOutputStream

 
org.apache.commons.fileupload.DefaultFileItemFactory.createItem(DefaultFileI
temFactory.java:103)

 
org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.jav
a:350)

 
org.apache.commons.fileupload.FileUploadBase.parseRequest(FileUploadBase.jav
a:302)

 
org.apache.catalina.manager.HTMLManagerServlet.doPost(HTMLManagerServlet.jav
a:157)

                javax.servlet.http.HttpServlet.service(HttpServlet.java:647)

                javax.servlet.http.HttpServlet.service(HttpServlet.java:729)

note The full stack trace of the root cause is available in the Apache
Tomcat/5.5.27 logs.

 

Apache Tomcat/5.5.27

 

Does anyone have an idea about what causes the problem?

 

Thank you in advance,

Nikos Spanoudakis

 

Nikolaos Spanoudakis

Laboratory Teaching Assistant

 <http://www.amcl.tuc.gr/en> Applied Mathematics and Computers Laboratory

Department of Sciences

 <http://www.tuc.gr/> Technical University of Crete

Addr: University Campus, Kounoupidiana, 73100, Chania, Greece (GR)

Tel: +30 2821037744

Fax: +30 2821037842

Web:  <http://users.isc.tuc.gr/~nispanoudakis/>
http://users.isc.tuc.gr/~nispanoudakis/

 

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message