tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeffrey Janner" <Jeffrey.Jan...@PolyDyne.com>
Subject RE: Windows x64 Installer
Date Mon, 08 Jun 2009 14:02:21 GMT
Chuck -
Thanks for the info and lead to check something else.
I am all IPv4 here, though the IPv6 services may still be enabled on
that system.  I will need to check.
I got the box in and setup with minimal customizations and was trying to
get this rolled out quickly (I do this because a lot of our customer
base does the same, believe it or not).
I'll go dobule-check the box and make sure I've got the IPv6 stuff
turned off and try again.
Jeff

-----Original Message-----
From: Caldarale, Charles R [mailto:Chuck.Caldarale@unisys.com] 
Sent: Tuesday, June 02, 2009 11:07 PM
To: Tomcat Users List
Subject: RE: Windows x64 Installer

> From: Jeffrey Janner [mailto:Jeffrey.Janner@PolyDyne.com]
> Subject: RE: Windows x64 Installer
> 
> Now the reason why 4) below was not working (all 64-bit), is that I
> didn't have an address specified in my <connector> tag.  Apparently,
at
> all windows revs prior to 2008 server, if you didn't supply an IP
> address, Windows would gladly supply 0.0.0.0, but now at 2008 it
> doesn't (possibly vista also?).

Works fine on my Vista 64 box, with no address attribute for the
<Connector>.  Looks like there's some 2008 Server setting that's
ignoring IPv4 and using only IPv6 if no bind address is given.

> Instead of seeing 0.0.0.0:80 in the first column, you'll 
> see [::]:80.

On my Vista 64 box, I see 0.0.0.0:8080 but not [::]:8080, with no
address attribute in my <Connector>.  I've got IPv6 disabled on my
router, so I can't test that at the moment.

> there are a number of these [::] addresses in the list,
> so MS possibly hasn't ported all their services yet.

Has nothing to do with porting services, but rather with IPv6-only being
the default on your installation.  I do see both IPv4 and IPv6 addresses
in listening mode for the various Windows services on my system.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
MATERIAL and is thus for use only by the intended recipient. If you
received this in error, please contact the sender and delete the e-mail
and its attachments from all computers.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org



*******************************  NOTICE  *********************************
This message is intended for the use of the individual or entity to which 
it is addressed and may contain information that is privileged, 
confidential, and exempt from disclosure under applicable law.  If the 
reader of this message is not the intended recipient or the employee or 
agent responsible for delivering this message to the intended recipient, 
you are hereby notified that any dissemination, distribution, or copying 
of this communication is strictly prohibited.  If you have received this 
communication in error, please notify us immediately by reply or by 
telephone (call us collect at 512-343-9100) and immediately delete this 
message and all its attachments.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message