tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: tomcat hang when start with "service tomcat start"
Date Tue, 30 Jun 2009 15:26:14 GMT
zhicheng wang wrote:
> 
> 
> hi
> 
> thanks for the reply. we downloaded tomcat from apache so it is real tomcat. the start
upscript was also downloaded from internet (not the redhat one), with some modifications and
has been running fine for a few years.
> 
> the problem began when we started running a Grails app (as ROOT.war) as the hang point
indicated
>  INFO: Initializing Spring root WebApplicationContext
> 
Ha, that may be another matter altogether.
I have an old system like that, with an old CPU and not too much RAM, 
and this one webapp which takes 15 minutes to initialize whenever I 
restart Tomcat.
During that time, Tomcat is using 99% of the system's CPU time.
Are you sure that this is not simply the case here ?

You could check with "top" what really happens.

You could also make this webapp into a non-ROOT webapp, and not start it 
right away.  I believe there is a <load-on-startup> parameter for that 
in the web.xml of the application, which you can set to 0.
Then the app will only initialise when you first call it.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message