tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: jk Status not showing errors
Date Tue, 02 Jun 2009 19:45:22 GMT
On 02.06.2009 21:40, Matthew Laird wrote:
> I'm not seeing anything like that.  I just took both Tomcats down, I
> instantly get the 503 from Apache when I try to load the application.

Assuming that there is no mod_proxy in the game. When there is a 503,
you will have [error] log lines in the JK log.

> However tailing the mod_jk.log, I just see entries like this:
> 
> [Tue Jun 02 12:36:23 2009] jkstatus www.innatedb.ca 0.000360
> [Tue Jun 02 12:36:26 2009] jkstatus www.innatedb.ca 0.000263
> [Tue Jun 02 12:36:39 2009] production www.innatedb.ca 0.498998
> [Tue Jun 02 12:36:40 2009] jkstatus www.innatedb.ca 0.000282

Note that these lines only contain a single request to the backend, the
one with "production".

> mod_jk seems happy sending the requests to Tomcat, and doesn't seem to
> notice there's no actual Tomcat responding.  Only after a few minutes
> does the JK Status screen go to ERR/REC for both.

> I would think this is the kind of thing mod_jk should notice instantly,
> when there's no Tomcat where there should be one.
> 
> Or am I missing something?

Show us your full access and jk log.

Regards,

Rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message